A blogging problem, contd.

Over the last three days, I’d been having a strange issue with WordPress. If you read a post I published yesterday that briefly discussed WordPress’s pros and cons, you might remember I mentioned that WordPress 4.x seems to be having an identity problem. WordPress’s back-end has been managed by what’s called the WP admin area. About two years ago, the company released a new interface for a section of that area, called ‘My Sites’. This split up was – is – quite confusing because there’s no theme or predictability in terms of which feature can be found in which part of the CMS.

The stark contrast in the UI/UX also indicates that WordPress doesn’t know what kind of a platform it wants to be: does it want to allow users to use ‘My Sites’ to build websites in a clean and admittedly intuitive environment or does it want them to get their hands (relatively) dirty in the WP admin area? If anything, this is a lack of vision. It’s dangerous.

The issue I’ve been having is this: since I launched Synecdoche a few days ago, I’d wanted to move the followers and subscribers on my previous WP blog, gaplogs.net, over. Gaplogs was on a WP account attached with Email A and Synecdoche, on an account with Email B. For this, I had to transfer ownership of Gaplogs to Email B. This step took me over two days for a frustrating reason. Earlier, I had a ‘Standard’ account, so for help with the process, I looked in WP’s documentation, which said: “Contact us and we’ll help you with the migration”. That ‘Contact us’ link turned out to be for the forums. See the loop?

So I dropped my question there, waited a day, and some other user came along and added the tag ‘modlook’. I had no idea that I was supposed to do this. Shortly after, a forum mod showed up and emailed me some guidelines.

Once I transferred ownership of Gaplogs to Email B, I didn’t want to wait around on WP’s forums again not knowing what to do. So I upgraded to the ‘Personal’ plan for $36 and avail chat support. It got weirder. Two people on chat couldn’t help me migrate subscribers/followers from one blog to the other. Between both of them, I’d spent over two hours sitting around, patiently answering their questions. I was eventually told that there was a bug and that they would stay in touch with me over email.

What does the split UI have to do with this? Quite a lot because it made moving Gaplogs from Email A to Email B hell. At one point, the support staff was confused about where to find/do what. I even found out there are two separate dashboards on which to manage your sites: one on the WP admin area (dashboard.wordpress.com) and one on the ‘My Sites’ area (wordpress.com/sites) – with different levels of control on each dashboard. And the almost-last-straw was when I finally received an email this morning saying,

In order to migrate followers/subscribers, you actually don’t need to transfer the source blog to the same account as the destination blog, as you were informed by my colleague through the chat you’d had a couple of hours before chatting with me. He probably misunderstood your request.

Thanks, dude.

I’m pretty sure my original problem was very simple to achieve, and I don’t understand what could go so wrong. I’ve been with WordPress.com for eight years – I’ve never had such terrible experience with support. I’m just glad I didn’t stick around with the forums option or who knows how long this would’ve taken. However, I did cancel my subscription to the ‘Personal’ plan, which took the custom domain upgrade with it.

Update: This morning, a WP Support member offered me a sweet discount on the ‘Personal’ plan should I choose to buy it again. So I went for it. Gah.

Featured image credit: Pexels/pixabay.

One thought on “A blogging problem, contd.”

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>